Using $this when not in object context in ../core/lib/ETSQLQuery.class.php(666) : regexp code on lin

  1. 5 years ago

    Using $this when not in object context in ../core/lib/ETSQLQuery.class.php(666) : regexp code on line 1

  2. Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in ../core/lib/ETSQLQuery.class.php on line 666
    ? =\

  3. 4 years ago

    [deleted]

    22 Aug 2015

    i have same problem.
    Dunno todo

    Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /var/www/html/esoTalk/core/lib/ETSQLQuery.class.php on line 666
    $ php5 -v                      
    PHP 5.5.9-1ubuntu4.11
  4. @sizonov_stas i have same problem.
    Dunno todo

    Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /var/www/html/esoTalk/core/lib/ETSQLQuery.class.php on line 666

    $ php5 -v PHP 5.5.9-1ubuntu4.11

    It's most likely that your server needs to update MySQL.

  5. [deleted]

    24 Aug 2015

    @Felli It's most likely that your server needs to update MySQL.

    libmysql - 5.5.44
  6. [deleted]

    26 Aug 2015

    @Felli

    Its not about upgrading MySQL, but downgrading that is needed here!

    But its just a warning and you can ignore it. If you don't want it to be displayed, set the following to false in your config.php:

    $config["esoTalk.debug"] = true;
  7. @sizonov_stas i have same problem.
    Dunno todo

    Deprecated: preg_replace(): The /e modifier is deprecated, use preg_replace_callback instead in /var/www/html/esoTalk/core/lib/ETSQLQuery.class.php on line 666

    $ php5 -v PHP 5.5.9-1ubuntu4.11

    This is NOT MySQL issue. This is because preg_replace is being deprecated in PHP. We've started to update this in the latest dev version on github.

 

or Sign Up to reply!