Warning: is_dir(): open_basedir restriction in effect.

  1. 3 years ago

    [deleted]

    9 Feb 2016

    Hello,

    After transferring the forum to a new host trigger alerts:

    Warning: is_dir(): open_basedir restriction in effect. File(/) is not within the allowed path(s):
    Warning: mkdir(): open_basedir restriction in effect. File(/) is not within the allowed path(s):
    /core/lib/functions.general.php on line 133

    You can see it here - http://forum.warmach.pinkappgames.com/

    Can you help me?

  2. Could you give us more information? For what's needed please read this post here for a better understanding of what we need to help you. :)

  3. [deleted]

    9 Feb 2016

    @Felli Could you give us more information? For what's needed please read this post here for a better understanding of what we need to help you. :)

    Server OS: Centos-7
    Dedicated hosting
    PHP 5.4.16 (native)
    MySql 5.5.41
    Apache/2.4.6

    php error log - empty :(

    open_basedir: none

  4. @odin84 Server OS: Centos-7
    Dedicated hosting
    PHP 5.4.16 (native)
    MySql 5.5.41
    Apache/2.4.6

    php error log - empty :(

    open_basedir: none

    Try enabling the debug plugin, another thing this could be is a mix up with your database, is this a fresh install with new database or migrated database?

  5. [deleted]

    9 Feb 2016

    @Felli Try enabling the debug plugin, another thing this could be is a mix up with your database, is this a fresh install with new database or migrated database?

    hmm.. can't enable the plugin..

    DB was migrated.

    Maybe problem with permissions (folders)?

  6. @odin84 hmm.. can't enable the plugin..

    DB was migrated.

    Maybe problem with permissions (folders)?

    You can enable the plugin manually, check the Troubleshooting . If this doesn't work try a fresh install with a different database (To make sure it's not a server issue.)

  7. When you moved the database did you also move hosts? If anything the issue lies in the new files (or current files) not having correct permissions, try updating the chmod permissions with their correct permission mask(s) and it should take this error away.

  8. [deleted]

    10 Feb 2016

    Hello,

    Figured out the problem. After transferring all the files had access 644. I corrected the access rights to files and folders as on the old hosting and it worked.

    Tnx!

  9. Great to hear! As a reference @odin84 would you mind marking my reply as the answer to your question (so that if any members get similar errors they will see the answer marked directly below your question)?

    Thanks!

 

or Sign Up to reply!