Facebook login

  1. 3 years ago

    [deleted]

    3 Apr 2016

    Is there a way to set up a facebook login for esotalk? People are now too lazy to sign up a forum.

  2. Yes there is in fact a way, but it requires some editing, and the OpauthConnect plugin, hope this helps. :)

  3. [deleted]

    8 Apr 2016

    @Felli Thank you for everything, you almost answered all of my questions! I made it work but there are some problems. Icons on the login page are not showing. I've also tried with g5 but no luck. And,Google+ login works like charm however, facebook login does not work. After registering it redirects me a page which give "can not be reached" error. The url of the page is like: "domain.com/user/social/setup"

    I can accept that facebook login does not work but I have to do something about icons. I replaced them other images from web still nothing...

  4. Edited 3 years ago by Felli

    @casperas @Felli Thank you for everything, you almost answered all of my questions! I made it work but there are some problems. Icons on the login page are not showing. I've also tried with g5 but no luck. And,Google+ login works like charm however, facebook login does not work. After registering it redirects me a page which give "can not be reached" error. The url of the page is like: "domain.com/user/social/setup"

    I can accept that facebook login does not work but I have to do something about icons. I replaced them other images from web still nothing...

    For Facebook, make sure that you've enabled the app through the app settings on Facebook Developers (You'll need to have an email as well as all the required information filled out), in addition you'll have to make sure that you're using a secure link (HTTPS://YOUSITE.COM ) in the website tab. As for the icons, I myself just replaced them, but from what I'm told it's an issue with the plugin itself, it's best to seek the plugin from the BitBucket repository. :)

  5. [deleted]

    8 Apr 2016

    Yes, I'm already using BitBucket repository. I edited it as you said in another post. Also google+ login only works in Chrome, it gives an error in other browsers. I didn't set a secure link in the web site tab. I don't have ssl certificate for my site. But I'll try to do it, maybe it's not necessary to have ssl :)

    Edit: Do I need to change both of the urls?

    One: Valid OAuth redirect URIs

    Other : Normal site url

    Edit2: I've changed the url in the web tab and still the same error:

    After registering(which doesn't get e mail automatically. You still type it manually)

    Can not reach this site:

    yourdomain.com/index.php/user/social/setup

    Why after .com I have to put index.php? If I don't put it on the app page. App doesn't work att all

    Edit3: I've checked the ftp and in the OpauthConnect/view plugin folder there is no user folder, there is directly social directory. How can I find this "setup" It seems that problem it is.

    Can you send me OpauthConnect plugin from your ftp? I'd like to compare it with mine.

  6. Edited 3 years ago by Felli

    The plugin only creates the connection between Social sites and your esoTalk installation, as for the URL from what I remember you only need the install directory, mean http://yourdomain.com/forum or what ever the directory is that you're using (This is for Facebook), Twitter can go through the same thing, or you can set the path to.

    OpauthConnect Setup v1.0+

    Steps to install
    Download and extract plugin
    Rename plugin folder to OpauthConnect (case sensitive!)
    Move plugin to esoTalk plugin directory (in newest version it is "addons/plugins")
    Enable plugin on esoTalk administration page
    Check needed social networks and enter credentials
    Go to your social application settings and add some info:

    For Facebook:
    Go to http://developers.facebook.com
    Select your application
    Select Settings in left menu
    Add your website (or edit existing Site URL)
    Navigate to Advanced tab
    Enable Client OAuth Login
    Add to Valid OAuth redirect URIs value
    http://your-forum.com/user/social/facebook[/s]

    This isn't needed to be done for the login to work, this is more optional than anything, all you have to do is add your basic domain name to the required feilds and save, note that the required feilds for this to work is website url where the installation was done for esoTalk.

    Select Status & Review in left menu
    Make your application public

    For Google:
    Go to http://code.google.com/apis/console
    Select APIs & auth -> Credentials in left menu
    Create new Client ID or edit existing
    Set to Authorized redirect URI value
    http://your-forum.com/user/social/google/oauth2callback

    For Twitter:
    Go to http://dev.twitter.com/apps
    Select your application
    Navigate to Settings tab
    Set to Callback URL value
    http://your-forum.com/user/social/twitter/oauth_callback

    For Vkontakte:
    Go to http://vk.com/apps?act=settings
    Find your application and click Manage
    Navigate to Settings tab
    Set to Base domain your domain name (e.g. your-forum.com )
    Set to Site address your site address (e.g. http://your-forum.com )
    Add following code where you want to display login buttons

    <?php $this->trigger("RenderOpauth"); ?>

    Steps to update from v1.0+ to v2.0+

    One note before we start. After updating you will lose some information about users, but no worries. This will not affect Google and Facebook users (they just need to press "complete authorization" button after first login attempt), but Twitter users have to enter and confirm their email address once more.
    Backup your database (Recommended)
    Don't forget to backup your custom templates (if any)
    Update your config file "config/config.php"
    There is no way to update it automatically, so you have to do it by yourself.
    By default there is no writing permission to config file. You have to add it first.
    Find lines started with prefix plugin.opauthconnect and replace this prefix to OpauthConnect
    Do needed steps to instal

  7. As for index.php did you setup Friendly URLs ? If not this will depend on what your server supports. I suggest finding which of the three options your server has and follow the instructions given. ;)

  8. [deleted]

    9 Apr 2016

    Yes my url type the second one. And, I already did everything as instruction says, I couldn't make it work. I know ask so much but, can you please upload your own Opauth Connect plugin on your ftp? Maybe you did some change which you don't remember or something else. It'd be soo nice.

  9. At the moment the one from the original post for OpauthConnect is the one that I use. The only other thing I can think of is a misconfiguration being done.

  10. [deleted]

    9 Apr 2016

    @Felli Well, I did everything like on the instructions again and again, Google Login works but still have problem with google and buttons. I gave up! Time to go for Flarum I guess. Even though I like Esotalk more than Flarum.

 

or Sign Up to reply!