OpauthConnect

  1. ‹ Older
  2. 6 years ago

    Got another error:

    Fatal error: require_once() [function.require]: Failed opening required 'C:\Vertrigo\www\eso/plugins/C:\Vertrigo\www\eso\plugins\Opauth/lib/Opauth.php' (include_path='.;C:\Vertrigo\Smarty') in C:\Vertrigo\www\eso\plugins\Opauth\plugin.php on line 15

    can someone fix?

  3. Edited 6 years ago by alex21

    There is a windows users problem with

    end(explode("/", __DIR__))

    __DIR__ holds backslashes instead of forward slashes.

    I've noticed another problem with plugin folder name and have decided to change plugin.php on 15 line from

    require_once PATH_PLUGINS."/".end(explode("/", __DIR__))."/lib/Opauth.php";

    to fixed folder name "Opauth"

    require_once PATH_PLUGINS."/Opauth/lib/Opauth.php";

    You can download plugin.php again or just change it by yourself.

  4. oops, there's no option for logging in with the forum account after installing the plugin...

  5. It must have face book and twitter login

  6. I'm just install now this plugin, but i have a problem... when i click Setting on Plugin manager: it only display "Opauth.connect Settings" ... and i can't find the file to config api social network manualy => in the login lightbox, i don't see annything change, please help me for this.

    @alex21

  7. Edited 6 years ago by Sways

    I fixed problem display only "Opauth.connect Settings" when i click Setting, input attibu => click Save Changes => I click Setting again => But nothing change. Can you help me ?

    p/s: i try input id key and api key directly in file plugin.php but notting happen :(

  8. I get "cannot redeclate class Opauth" when I open the plugins-page. Does anyone know how to fix it?

  9. Ya very true, as everybody know social media provides a wider platform to enhance the business. It would be the right way to engage customers and share new updates.

  10. Thank you for making it public.

    I have one issue. I have uploaded all of the files to addons/plugins/Opauth > logged on as an admin > then clicked on addons > find Opauth.connect > click on "Enable" it enables successfully > settings and this is the only thing that shows "Opauth.connect Settings".

    So I'm puzzled of why it does not work.

  11. I downloaded files from github uploaded them to plugins/Opth folder and when I logged in as admin and moved to Plugins
    I got the following error

    Fatal error: require_once(): Failed opening required '/var/www/vhosts/inei/supportline.inei.me/httpdocs/addons/plugins/Opauth/lib/Opauth.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/vhosts/inei/supportline.inei.me/httpdocs/addons/plugins/opauthconnect-master/plugin.php on line 14

  12. Edited 6 years ago by alex21

    Now you can try out new version of plugin here https://github.com/alex21/opauthconnect
    It is compatible with 1.0.0g2 and 1.0.0g3 forum versions.
    Now no need to change folder name

  13. Edited 6 years ago by ex_mac

    @alex21, make for public some changes of attachment plugin like on forum.mikrobill.com
    for inserting images to post...

    if you have time ... :)

  14. I copied Opauth folder to Plugins dir and created a facebook application too. I went to Opaauth settings in adminpanel and filled the
    Appsecret and App ID saved it and tried login.Nothing shows up no facebook login nothing its all like before.
    Where could be the mistake ?

  15. Could you provide me your steps to install plugin.
    Did you do 4th step from here https://github.com/alex21/opauthconnect/wiki ?

  16. @ex_mac @alex21, make for public some changes of attachment plugin like on forum.mikrobill.com
    for inserting images to post...

    if you have time ... :)

    I think a bit later :)

  17. Edited 6 years ago by laalkitaab

    @alex21 Thanks alot. I realy missed 4th step and after adding that in my login.php I got facebook login button on my login page, but when I try to login it takes me to a 404 page. Screen shot attached.

  18. Made some fixes.
    Try to replace your plugin.php in opauthconnect directory with newest one from https://github.com/alex21/opauthconnect/blob/master/plugin.php

  19. Downloaed n reinstalled whole plugin with new plugin.php
    when i try to open plugins in admin panel i get this error

    Fatal error: Call to a member function settings() on a non-object in /home/content/37/11629337/html/forum/core/controllers/admin/ETPluginsAdminController.class.php on line 52

  20. I'm sorry to keep you waiting. If problem still exists, try to download fixed version from github.
    Actually I changed classname from 'ETPlugin_Opauthconnect' to 'ETPlugin_opauthconnect' in plugin.php on line 16. You can try to do the same by yourself.
    I cannot reproduce your problem exactly, but guess it appears because of case sensitivity in your system.

  21. Deleted everything.
    Redownloaded and reinstalled esoTalk from github. (successfully)
    Redownloaded and reuploaded Opauth plugin.

    Go > Admin > Plugins >Fatal error: Call to a member function settings() on a non-object in /home/content/37/11629337/html/forum/core/controllers/admin/ETPluginsAdminController.class.php on line 52

  22. Newer ›
 

or Sign Up to reply!