1. ‹ Older
  2. 7 years ago


    23 Oct 2012 Moderator

    Are you using a version of PHP older than 5.3.0 ? In this case add

    <?php if ( !defined('__DIR__') ) define('__DIR__', dirname(__FILE__)); ?>

    at the beginning of plugin.php

  3. @ram Are you using a version of PHP older than 5.3.0 ? In this case add

    <?php if ( !defined('__DIR__') ) define('__DIR__', dirname(__FILE__)); ?>

    at the beginning of plugin.php


  4. Deleted 7 years ago by ram
  5. Edited 6 years ago by AFN

    comment removed by author.

  6. Hi, Ive installed the plugin successfully and have received a App ID and App Secret which I have saved in the plugin settings for Facebook.

    Nothing happens. I tried logging in but there is no option for logging in with facebook.

  7. I can't integrate it, any help?

    I through it in plugins folder and enable it. I guess that's? no?
    I added Facebook strategy in strategies folder and enabled from CP (typing secret and ID)
    I tried to navigate manually /user/auth/Facebook or even /user/auth, but it redirects to main page not doing anything.

    any suggestion where to start?

  8. Deleted 7 years ago by Toby
  9. Got another error:

    Fatal error: require_once() [function.require]: Failed opening required 'C:\Vertrigo\www\eso/plugins/C:\Vertrigo\www\eso\plugins\Opauth/lib/Opauth.php' (include_path='.;C:\Vertrigo\Smarty') in C:\Vertrigo\www\eso\plugins\Opauth\plugin.php on line 15

    can someone fix?

  10. Edited 7 years ago by alex21

    There is a windows users problem with

    end(explode("/", __DIR__))

    __DIR__ holds backslashes instead of forward slashes.

    I've noticed another problem with plugin folder name and have decided to change plugin.php on 15 line from

    require_once PATH_PLUGINS."/".end(explode("/", __DIR__))."/lib/Opauth.php";

    to fixed folder name "Opauth"

    require_once PATH_PLUGINS."/Opauth/lib/Opauth.php";

    You can download plugin.php again or just change it by yourself.

  11. oops, there's no option for logging in with the forum account after installing the plugin...

  12. 6 years ago

    It must have face book and twitter login

  13. I'm just install now this plugin, but i have a problem... when i click Setting on Plugin manager: it only display "Opauth.connect Settings" ... and i can't find the file to config api social network manualy => in the login lightbox, i don't see annything change, please help me for this.


  14. Edited 6 years ago by Sways

    I fixed problem display only "Opauth.connect Settings" when i click Setting, input attibu => click Save Changes => I click Setting again => But nothing change. Can you help me ?

    p/s: i try input id key and api key directly in file plugin.php but notting happen :(

  15. I get "cannot redeclate class Opauth" when I open the plugins-page. Does anyone know how to fix it?

  16. Ya very true, as everybody know social media provides a wider platform to enhance the business. It would be the right way to engage customers and share new updates.

  17. Thank you for making it public.

    I have one issue. I have uploaded all of the files to addons/plugins/Opauth > logged on as an admin > then clicked on addons > find Opauth.connect > click on "Enable" it enables successfully > settings and this is the only thing that shows "Opauth.connect Settings".

    So I'm puzzled of why it does not work.

  18. I downloaded files from github uploaded them to plugins/Opth folder and when I logged in as admin and moved to Plugins
    I got the following error

    Fatal error: require_once(): Failed opening required '/var/www/vhosts/inei/supportline.inei.me/httpdocs/addons/plugins/Opauth/lib/Opauth.php' (include_path='.:/usr/share/php:/usr/share/pear') in /var/www/vhosts/inei/supportline.inei.me/httpdocs/addons/plugins/opauthconnect-master/plugin.php on line 14

  19. Edited 6 years ago by alex21

    Now you can try out new version of plugin here https://github.com/alex21/opauthconnect
    It is compatible with 1.0.0g2 and 1.0.0g3 forum versions.
    Now no need to change folder name

  20. Edited 6 years ago by ex_mac

    @alex21, make for public some changes of attachment plugin like on forum.mikrobill.com
    for inserting images to post...

    if you have time ... :)

  21. I copied Opauth folder to Plugins dir and created a facebook application too. I went to Opaauth settings in adminpanel and filled the
    Appsecret and App ID saved it and tried login.Nothing shows up no facebook login nothing its all like before.
    Where could be the mistake ?

  22. Newer ›

or Sign Up to reply!