need help about apache rewrite

  1. 6 years ago
    Edited 6 years ago by buobuk

    i use the rule:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteRule ^(.*)$ index.php\?p=$1 [QSA,L]
    </IfModule>

    there is some url cannt work

    when it readed, it can work by xxx.com/16
    but it unreaded , it can not work, the url turn to xxx.com/161 with 404

    or

    when it readed, it can work by xxx.com/13
    but it unreaded , it can not work, the url turn to xxx.com/131 with 404

  2. check if you have correctly instaled mod rewrite

    maybe try disable friendly url
    add to config.php
    $config["esoTalk.urls.friendly"] = false;
    $config["esoTalk.urls.rewrite"] = false;

  3. 5 years ago

    I have the same problem. I have a proper .htaccess file, esoTalk.urls.friendly and esoTalk.urls.rewrite are both true, and I get a Page Not Found error. When I set them to false, the URLs are broken. Please fix it.

  4. Edited 5 years ago by Tristan

    Make sure the apache vhost config has the following:

    <Directory /var/www/vhosts/<YOUR DOMAIN>/httpdocs>
    Options Indexes FollowSymLinks MultiViews
    AllowOverride all
    Order allow,deny
    allow from all
    </Directory>

    AllowOverride all is the part you are looking for.

 

or Sign Up to reply!